WeLoveCSS Logo
Home Profile Members Search Rules Help New Posts



WeLoveCSS > WEB DESIGN > Browser Compatibility > hover background not doing anything in safari

Reply
  Thread Tools Display Modes
Old 17th August 09, 10:22 PM   #1
franzzz
WLC Member
 
Join Date: Aug 2009
Posts: 4
Default hover background not doing anything in safari

On http://decojardin.info/ I want the background-image of the main menu to change on hover (it does work in Firefox), but it doesn't in Safari. Tried everything, any idea what may be the issue?
franzzz is offline   Reply With Quote
Old 18th August 09, 01:07 AM   #2
meesa
WLC Mod
 
meesa's Avatar
 
Join Date: Jul 2009
Location: Milky Way Galaxy
Posts: 3,711
Default Re: hover background not doing anything in safari

It works in Safari for me.
__________________
Praise be to the Lord God for the ability to learn, the capability to analyze, and the time to help users on this forum.
meesa is offline   Reply With Quote
Old 18th August 09, 01:30 AM   #3
franzzz
WLC Member
 
Join Date: Aug 2009
Posts: 4
Default Re: hover background not doing anything in safari

hm, so after clearing my cache it suddenly works, really strange!
franzzz is offline   Reply With Quote
Old 18th August 09, 01:32 AM   #4
meesa
WLC Mod
 
meesa's Avatar
 
Join Date: Jul 2009
Location: Milky Way Galaxy
Posts: 3,711
Default Re: hover background not doing anything in safari

Not really, most likely Safari just had a previous version of you code stored already, and that is the CSS file it was using.
__________________
Praise be to the Lord God for the ability to learn, the capability to analyze, and the time to help users on this forum.
meesa is offline   Reply With Quote
Old 18th August 09, 12:10 PM   #5
franzzz
WLC Member
 
Join Date: Aug 2009
Posts: 4
Default Re: hover background not doing anything in safari

hm, don't think that safari was using a previous version of my code, today it wouldn't work again until I reset safari once again, and I haven't changed anything since the last time I reset it. Is it possible that Safari just ignores a couple of things when it caches style sheets?
franzzz is offline   Reply With Quote
Old 18th August 09, 05:31 PM   #6
meesa
WLC Mod
 
meesa's Avatar
 
Join Date: Jul 2009
Location: Milky Way Galaxy
Posts: 3,711
Default Re: hover background not doing anything in safari

Hmm, that is weird.

Try waiting several hours before visiting the site again, but before you go to it, upload the HTML file and the CSS again, and see if it will work then.

Before doing that, see if it's messed up again.
__________________
Praise be to the Lord God for the ability to learn, the capability to analyze, and the time to help users on this forum.
meesa is offline   Reply With Quote
Reply


Thread Tools
Display Modes
Linear Mode Linear Mode

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump


All times are GMT. The time now is 03:24 PM.



Home | Advertise | Contact Us | Top
Home | Advertise | Contact Us | Top

Copyrightę 2006 WeLoveCSS.com. All Rights Reserved.
Powered by vBulletin Version 3.8.4 Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.